WinjJammer Player Help Index

WinJammer Player is a program which plays MIDI songs. It allows you to create "Albums" of
songs which will be played in sequence. Because WinJammer Player does all this playing in
the background, you can now listen to your favorite songs while you do other things. If you
are running Windows in extended mode (386 mode), WinJammer Player will even play while
you are in a DOS session.

WinJammer Player is not a free program, but is being distributed as part of the WinjJammer
package under the Shareware concept. This allows you to test the program to determine
whether it is worth anything, and then buy it if you are going to use it. You must register
the program if you are going to use it. See the help topic Registration for registration
instructions.

This index contains a list of all Help topics available for WinJammer Player. For information
on how to use Help, press F1 or choose Using Help from the Help menu.

Quick Start Quick start up help for first time users.
Commands Information on all available commands.
Keys List of the keys used in WinJammer Player.

Registration How to Register WinJammer Player.



Quick Start

Welcome to WinjJammer Player. We will try to get you going as fast as possible by
describing how to play the sample songs. The sample songs are all set up for a Roland MT-
32 or equivalent, so you will have to revoice them using WinjJammer before trying to play
them here.

Configuration

Before you can play a song the MIDI hardware must be configured. The MIDI Configure
command is used to do this.

Creating an Album

WinJammer Player deals with lists of songs to play, called Albums. It is easy to build an
album.

1. Clear Album. The listbox labeled Songs shows the contents of the current aloum. Itis
empty when the program is started. If it is not empty now, use the File New command to
clear it.

2. Add Songs. Press the button labeled Add Song. A dialog will appear listing all of the
songs in the current directory. To select a single song, highlight it in the list and press Add.
The song name will appear in the alboum. The button labeled Add All will add all of the
songs displayed to the album. When you are finished, press Done or the Esc key.

Playing the Album

Now that we have an album of songs, we can press the Play button and WinJammer Player
will start to play them in sequence. Don't be alarmed if the Player suddenly disappears
when you press Play. This is so that you can go and do other things while it plays. This is
controlled by the Minimize switch on the Options menu.

Stopping Play

Play will stop at the end of the album unless the Loop switch is used. Play can be stopped
by pressing the Stop button, or selecting Stop from the system menu.



Commands

This index contains a list of the Help available on the various Winjammer Player Commands.
For information on how to use Help, press F1 or choose Using Help from the Help menu.

File Menu Create, Load or Save Albums.
Options Menu Change WinJammer Player Options.

Main Window Work with an Album.



Help

Open a New Album.

Save the Current Album

Save the Album after Asking for a File Name
Delete the Selected Song

Insert a New Song



Registration

As discussed in the index, Winjammer Player is being distributed as part of the Winjammer
package through Shareware. This allows you to evaluate the program to see if it performs
properly, before you have to pay for it. It does not allow you to "evaluate" the program
forever - if you use it after evaluating it for a week or two, then you must register.

To register WinJammer send me a note and a cheque or money order for $50 US. Please
include in your note your name, mailing address, current version number and computer/MIDI
setup. The current version information is found in the Help About dialog box. If you would
like a copy mailed to you, please add an additional $5, and | will send you the most recent
version available. Please note that registration for WinJammer includes registration for
WinJammer Player.

I will send your registration keys, which you can then use with the File Register command to
unlock the program. If you have a CompuServe account, | will send the registration keys
immediately via CompuServe mail, otherwise | will have to send you an old fashioned letter.

| can be reached at:

Dan McKee

69 Rancliffe Road

Oakville, Ontario

Canada

L6H 1B1
Please ensure that you use the correct postage. It currently costs 40 cents to mail a letter
from the US to Canada. | know a number of people have had their letters returned because
of insufficient postage.

I am also interested in knowing what MIDI boxes you have attached, as | am looking into
supporting machine specific things like patch names and drum note names. If | know what
you have, then maybe | can support it.

Software Excitement!

The good folks at Software Excitement! will also accept registrations for Winjammer. They
accept Visa/Mastercard, and will accept international orders. If you want a copy of the
program sent to you, they can also do this for a nominal charge.

Software Excitement! can be reached a number of ways. If you are a member of
CompusServe, they have a store in the "Electronic Mall" (GO SE) that you can use for free.

They will also take orders via normal mail, phone or fax at: Software Excitement! (Attn:

Registrations) 6475 Crater Lake Highway Central Point, OR 97502Toll Free Phone:
(800)444-5457Fax Number: (503)826-8090Non-Toll Free: (503)826-

8082

MIDILIB.DLL

A substantial amount of the effort that went into WinJammer was actually spent developing
MIDILIB.DLL - the code that actually runs the MPU-401. If you are trying to develop a
Windows program that uses a MIDI device, | may be able to help you out.

I am selling a developer's kit so that you can write your own Windows based MIDI programs.
This kit includes: printed documentation for the library, the needed include/library files,
some example programs with source, a registered copy of WinJammer and limited
distribution rights for MIDILIB.DLL. The price for the kit is $100 US, and any fees paid for



WinJammer are deductible from this price.

You will be able to distribute your programs through Shareware channels as long as you
make a registered copy of your program available to me. | will advertise your product with
all of the Shareware MIDI programs that | produce. You will have to acknowledge me as the
author of MIDILIB.DLL, and place certain information in your program's About box.

If you are interested in distributing MIDILIB.DLL in a commercial product, a separate
negotiated license is required. Please give me a call to discuss this. If necessary, | will
customize a DLL for you.

The*Drums
The first Shareware product using MIDILIB.DLL written by someone other than me has
recently been released. This is a great program called The*Drums, written by Fabio
Marzocca. Fabio's description of his program is:
New The*Drums V3.00 for Microsoft Windows! Universal Editor/Sequencer for drum
parts. Build your own drum patterns and songs, and save them as Standard Midi File
Format.
Check it out!
Support (How to contact me)
There are a number of channels that you can use to contact me. My CompuServe id is
70742,2052. A message there will reach me if sent via mail or if left in the MIDIFORUM. |
can also be reached on Internet as 70742.2052@compuserve.com.

I monitor the MIDI conferences on SmartNet, Rime, NorthAmeriNet, Intelec, and Interlink.
Address messages it to me to be sure | see it.

I can be reached by telephone at (416)844-1821. Please try to call between the hours of 7
and 9 PM, Eastern Time. If all else fails, you can always write me at the address above.



File Menu

The File menu includes commands that enable you to load or save albums, or create a new
album. To WinJammer Player, an album is a list of the songs that you would like played.

For more information about a File Menu command, select one of the following topics.

New Create a New Album.

Open Loads an Album File.

Save Saves the Current Album.

Save As Saves the Album under a Different Name.
Configure Configures the MIDI Device.

Exit Exits WinJammer Player.

Register Registers your copy of WinjJammer.



Options Menu

The Options menu includes commands which effect the operation of WinJammer Player. All
of these options are stored when you exit so that next time you use WinJammer Player you
do not have to customize WinJammer Player again.

For more information about one of the Options Menu commands, select one of the following
topics.

Loop Continuous Play.
Reset Send Reset Commands between songs.

Minimize Turn into an Icon when Playing.



Main Window

The Main Window contains the controls used to manipulate an album of songs, along with
the controls which control the playback.

For more information about one of the Main Window controls, select one of the following
topics.

Add Song Add a Song to the Album.
Delete Song Delete a Song from the Album.
Play Start the Album Playing.

Next Song Skip to Start of Next Song.
Stop Stop the Playback.

Pause Pause the Playback.



File New Command

The File New command is used to clear the current album from memory. It deletes all
songs, and reinitialises the system to its start up state.

If you have not saved the last changes you made to the current album, WinjJammer Player
will ask you if you would like to save them before clearing the album.



File Open Command

The File Open command is used to load an album from disk. It replaces the current album
in memory.

If you have not saved the last changes you made to the current file, WinJammer Player will
ask you if you would like to save your changes before loading the new album.

Short Cut Key: Ctrl+0



File Save Command

The File Save command saves the current album using the current file name. If there is no
current file name, the File Save command is the same as the File Save As command. Ifa
song was previously named using the File Save As command or if the file was loaded using
the File Open command, then the file on disk is overwritten by the album.

Short Cut Key: Ctrl+S



File Save As Command

The File Save As command saves the current album, after prompting for a file name. If the
entered file name exists, WinjJammer Player will prompt before overwriting the file.

Short Cut Key: Ctrl+A



File Configure Command

This command is used to configure WinJammer Player for the hardware on your particular
machine. You must do this before you can play or record.

The dialog box displayed is used to select the proper I/O base address and interrupt number
for the MIDI adapter. At this point, WinJammer Player only supports a Roland MPU-401 (or
compatible).

Once you have successfully configured WinJammer Player, this configuration information is
remembered in the WINJAMMR.INI file, so you should only have to configure once. The
configuration is also tested whenever WinJammer Player is started, to make sure your
equipment has not been changed.

Choose Default First

The original Roland MPU-401 came fixed at one spot: base I/O port of 330H and interrupt
number 2. There were no switches or jumpers that could be used to change this
configuration - you had to cut traces and use your soldering iron. Roland's current adapters
are similar, and don't really let you move the board around.

For this reason, the vast majority of machines with MIDI ports have them installed at this
default location. Unless you know for certain that the MIDI device had to be moved, choose
Default in the dialog box. This will probably work correctly.

Configuring for Non-Standard Installations

If you know what your configuration is, simply select the appropriate settings and press Ok.
When Ok is pressed, the device will be tested (a reset is performed), and if all is well, the
device is configured.

If you don't know what your configuration is, you will have to resort to the old trial and error
approach. You can try various settings until you find the correct one. Note that WinJammer
will probably detect an incorrectly set base I/O port address, and give you the message:
"Configuration Failed." If your machine simply hangs without giving you any warning (big
red switch time), then the base I/O port is probably correct but the interrupt number is
wrong. Try again with the same base I/O port address and another interrupt number.

As a Last Resort

In the event that the base 1/0O address you are listed is not in the dialog box, you can
manually edit the file WINJAMMR.INI to set the base address. WINJAMMR.INI is normally
found in your C:\WINDOWS directory.

There are two entries in WINJAMMR.INI which are used to determine the configuration of the
MIDI device. Both must be correct (and non-zero) for things to work.

The entry "lIOBase=?7?" contains the base I/O address of the device - as a DECIMAL number.
You can enter your base I/O address here. The entry "IRQ=" contains the interrupt number.
Simply enter the correct interrupt number in here.

When WinJammer starts up it will test the MIDI device and let you know if it disagrees with
your settings. If the machine hangs, you have probably configured for the wrong interrupt
number.



If you had to use this to configure WinjJammer, please send me a note telling me about your
setup so that the next guy will not have to do the same thing.

Still Having Problems?

| have had a few reports of the program not running properly on 286 based machines in
Standard mode. It seems to run in real mode however. I'm working on this at this point,
but | would love to hear from you if you are having similar problems. Please make sure you
write down and send me the information that is displayed when the configuration fails.

| have also had a number of questions about configuration which are hardware related. At
this point in time, WinJammer requires a Roland MPU-401 or equivalent. Sorry but a
Sound Blaster, Sound Blaster Pro, Thunder Board, ATl F/X Sound Board or Midiator won't
work. | am presently working on a version which will run under the Windows Multimedia
Extensions. Most of these devices will be supported through the MME at that time.



File Register Command

The File Register command is used to register your copy of Winjammer, which includes
WinJammer Player. Once registered, the reminder dialog will no longer appear. The track
name field will also be able to be entered and saved, and the About box will display the
registration information.

To register the program, you must carefully enter the registration information. Please take
care to enter the three fields exactly as | sent them to you, or the registration will fail.

For more information on registration, including the cost and how to do it, see the
Registration topic.



File Exit Command

The File Exit command will terminate WinJammer Player, and return to Windows. If the last
changes to the current album have not been saved, WinJammer Player will ask if you would
like to save them before exiting.

WinJammer Player will not let you exit or shut down Windows if an album is currently
playing. You must stop play first.



Options Loop Command

The Loop switch specifies what WinjJammer Player is to do at the end of the album. If this
switch is on (checked), playback will start again with the first song in the album.



Options Reset Command

The Reset switch is used to tell WinJammer Player to send out a reset sequence at the
beginning of each song. This can be very useful if a song changes a controller, and the
following song doesn't reset it.

The following MIDI reset sequence is transmitted on all channels:

Bx 7B 00 ;all notes all

Bx 01 00 ;modulation wheel to zero
Bx 07 7F ;volume to max (127)

Bx 40 00 ;sustain pedal off

Ex 00 40 ;centre pitch wheel



Options Minimize Command

The Minimize switch is used to ask WinJammer Player to minimize (turn into an icon) when
playback is started. This is handy when you are playing a number of songs in the
background.



Add Song Command

The Add Song pushbutton is used to add one or more song to the album. When the
pushbutton is pressed, or the Ins key is pressed, a dialog box is presented allowing you to
select one or more song to add to the album. The Add All button will add all of the listed
songs to the album. Press Done when you have added all of the songs.

Short Cut Key: Ins



Delete Song Command

The Delete Song pushbutton is used to delete the currently selected song. Simply select
the song you wish to delete from the album in the listbox, then press the Delete Song button

or press the Del key.

Short Cut Key: Del



Play Command

This command will start the playing of the current album. Playback starts with the currently
selected song, or the first song in the album.

The system menu (pull down from close box or clicking on Icon) includes this command.
This makes WinJammer Player easy to control when it is minimized.



Next Song Command

The Next Song commands causes the currently playing song to be stopped immediately. If
there is another song in the album, the album will continue playing with this next song.

The system menu (pull down from close box or clicking on Icon) includes this command.
This makes it easy to skip to the next song while the album is playing in the background.



Stop Command

The Stop command stops the play of the album immediately. Playing must be stopped
before WinjJammer Player can be closed, or Windows will terminate.

The system menu (pull down from close box or clicking on Icon) includes this command.
This facilitates shutting down Windows while an album is playing.



Pause Command

The Pause command stops the play of the album immediately. The next time that Play is
pressed then the playback of the current song will continue.

The system menu (pull down from close box or clicking on Icon) includes this command.
This is often convenient when running WinJammer Player minimized.



